Migration and update to JoomGallery 1.5

Last Updated on Monday, 13 February 2012 09:37

Since the PonyGallery ML our intention always was to provide users of older versions with the possibility to make an update if a newer version of the gallery was available. With the Updatezip for the PonyGallery it is possible to update any older version to 2.5.1

With publishing the JoomGallery we also provide the Migration manager to transfer the pictures from the PonyGallery ML to the JoomGallery. Also for the JoomGallery 1.0.0 there is an Updatezip available to actualize older versions.

This we also offer for the JoomGallery 1.5.5. It will be no longer a manual update which leads partly to some problems as e. g. 'SafeMode=on' or wrong file owner. You can use the autoupdate function to obtain the update or, if not possible, download the the Zip from our downloads and install them with the extension manager of Joomla!.
Don't deinstall the existent installation of Joomla! before.

The update process will recognize an older version of the galllery (since version 1.0) and modifies them to recent state. The images, categories are not deleted. You can find more details at this article.

How to make the change from the JoomGallery 1.0.0 to the native JoomGallery 1.5.5? This version have e. g. changes in the database. Therefore a database export/import and a simple replacement of the files is not longer possible. In this FAQ we will explain it on the basis of an example.

In the following scenarios the target system is based on the actual JoomGallery 1.5.5 in Joomla 1.5.x. For safety reasons you should always use the actual version of Joomla! 1.5.x. If necessary make an update before.

Please make an update of the database and the files in following steps:


From the PonyGallery ML 2.5.1 or lower under Joomla! 1.0.x

From PonyGallery ML in Joomla! 1.0


From the PonyGallery ML ported 2.5.1 (german) (native by Chraneco) in Joomla! 1.5.x

From PonyGallery ML in Joomla! 1.5


From JoomGallery 1.0.0 in Joomla! 1.5.x with activated Legacy Plugin

From JoomGallery 1.0 in Joomla! 1.5
Installation of the component at the backend of Joomla! (Extension Manager). Therewith the JoomGallery 1.0.0 will be updated automatically to the actual JoomGallery 1.5.x. In this process the database will be updated, unnecessary files deleted and other files updated if necessary.


From JoomGallery 1.5 in Joomla! 1.5.x

From JoomGallery 1.5 in Joomla! 1.5
Installation of the component (1.5) at the backend of Joomla! (Extension Manager). Therewith the JoomGallery 1.5 will be updated automatically to the actual version. In this process the database will be updated, orphaned files deleted and other files updated if necessary.

The FAQ will be constantly updated. We wish a successful migration and update. If you have any questions please post them in the Forum.